The issue with outbound calling was resolved at 5:17pm ET. All phone service is back to normal operation. We appreciate your patience as we dealt with the Federal Communications Commission (FCC) to resolve the issue.
Posted Aug 29, 2025 - 17:29 EDT
Update
There is a known issue with outbound calling that may be affecting some NDT/rmVoIP customers. Inbound calling is not affected by the issue. We appreciate your patience as we deal with a Federal Communications Commission (FCC) issue that is causing the incident. We understand the urgency of the matter and are working diligently to resolve the issue.
Posted Aug 29, 2025 - 09:02 EDT
Update
There is a known issue with outbound calling that may be affecting some NDT/rmVoIP customers. Inbound calling is not affected by the issue. Our upstream voice providers understand the urgency of the matter and are working diligently to resolve the issue.
Posted Aug 28, 2025 - 12:44 EDT
Identified
There is a known issue with outbound calling that may be affecting some NDT/rmVoIP customers. Inbound calling should not be affected by the issue. We are working diligently with our upstream voice providers to get a resolution to the issue.
Posted Aug 28, 2025 - 09:02 EDT
Update
We are aware that some customers are continuing to experience issues when making and receiving phone calls with their NDT/rmVoIP phone systems. We are working hard to identify the root cause of the problem. Until then, there may be further intermittent issues with the service.
Posted Aug 27, 2025 - 17:19 EDT
Investigating
We have identified an issue that is affecting some users ability to make and receive calls through NDT and rmVoIP. This issue is our top priority and we hope to have it resolved as soon as possible.
Posted Aug 27, 2025 - 15:50 EDT
This incident affected: Net Dial Tone (NDT) and rmVOIP.