The connectivity issue that was causing disruptions with Rent Manager Online (RMO) has been resolved.
We know how important Rent Manager is to you and your business and we sincerely apologize for the inconvenience.
Thank you again for your patience, The Rent Manager Team
Posted Jan 06, 2026 - 09:02 EST
Monitoring
We are continuing to address the issue causing difficulty with some users' speed and/or their ability to log into Rent Manager and will continue to monitor overnight. We're working diligently to resolve the problem and appreciate your patience. We apologize for the inconvenience.
Posted Jan 05, 2026 - 17:31 EST
Identified
We are continuing to address the issue causing difficulty with some users' speed and/or their ability to log into Rent Manager. We're working diligently to resolve the problem. We appreciate your patience and apologize again for the inconvenience.
Posted Jan 05, 2026 - 15:01 EST
This incident affected: Rent Manager Online (RMO).